"Your FreedomPop service is inactive due to an unforeseen technical issue."

Completed

Comments

100 comments

  • Thomas Harrison

    I am having the same issue. After reactivating my top-up credit (why does this credit expire in the first place??), and updating my payment information, my account now shows as inactive. Page that the message sends me to to contact technical support doesn't exist, and all emails to Freedom Pop are returned marked "CLOSED". 

    0
    Comment actions Permalink
  • Danny Arthur

    Same problem here.

    0
    Comment actions Permalink
  • Leszek Szyjka

    Getting the same exact problem that started last night. Created a ticket but it was closed asking to sign up for paid support :(

    I have rebooted the phone multiple times.

    I have even re-validated my Paypal billing connection but still technical issues. 

    xxx-xxx-3660

    Please help.

    Leszek

    0
    Comment actions Permalink
  • John Robert Puliatch

    I have the same exact issue with 2 months left! Need internet to navigate around this new place I moved to.

    0
    Comment actions Permalink
  • Scott Kolaya

    I also have "Your FreedomPop service is inactive due to an unforeseen technical issue"  arrr. my son was standing out in the cold rain waiting for me with his friends to pick him up, kept trying to text and call me but I didn't know my account wasn't working.  submitted a ticket #10133 24 hrs ago and still nothing!!!  Please help.

    0
    Comment actions Permalink
  • xiao yang

    I had same issue,Please someone can help me .

    my number is xxx-xxx-4195

    0
    Comment actions Permalink
  • Alexander Lam

    Hello, I am having the same issue. Please help me, Thanks!

     

    Edit: Nevermind, I solved it on my own. First I switched my payment method from Credit Card to Paypal. That didn't fix it, so a day later I switched it back to a different credit card. That time the service restored itself instantly. I had to try twice to add the credit card, the first time there was a "technical error"

    0
    Comment actions Permalink
  • Mike Davis

    As a follow-up, I had this issue and was able to resolve it by re-applying my credit card.  It was the exact same card as was already in the system, but as soon as I put it in again the error went away and my phone worked.

    I have a pre-paid annual plan which shouldn't require a credit card, but by having one in there it did solve the error.

    0
    Comment actions Permalink
  • chen li

    I have the same problem "service is inactive", it has been seveal days, please fix it ASAP, thanks!

    0
    Comment actions Permalink
  • FreedomPop Community

    Thanks for reaching out to us! 

    It looks as if your accounts are now in good standing. Please feel free to perform a soft reset by simply powering off and on your device to ensure everything synchronizing accordingly.

    However, should this not be the case, we've created a support ticket for you please reply there and we will gladly look into the account.

    0
    Comment actions Permalink

Post is closed for comments.